美文网首页蓝桥杯题目
[蓝桥杯]FJ的字符串

[蓝桥杯]FJ的字符串

作者: 二十五六岁的你 | 来源:发表于2020-01-30 19:35 被阅读0次

    问题 1461: [蓝桥杯][基础练习VIP]FJ的字符串

    题目描述

    FJ在沙盘上写了这样一些字符串:

    A1 = “A”

    A2 = “ABA”

    A3 = “ABACABA”

    A4 = “ABACABADABACABA”

    … …

    你能找出其中的规律并写所有的数列AN吗?

    输入

    仅有一个数:N ≤ 26。

    输出

    请输出相应的字符串AN,以一个换行符结束。输出中不得含有多余的空格或换行、回车符。

    样例输入

    3 
    

    样例输出

    ABACABA
    
    import java.util.Scanner;
    
    /**
     * Created with IntelliJ IDEA.
     * User: 76147
     * Date: 2020-01-27
     * Time: 16:09
     * Description:
     */
    public class FJ的字符串 {
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while (sc.hasNext()) {
                int n = sc.nextInt();
    
                StringBuffer buffer = new StringBuffer("A");
    
                for (int i = 1; i < n; i++) {
                    String temp = String.valueOf((char) ('A' + i));
                    buffer.append(temp + buffer.toString());
                }
                System.out.println(buffer.toString());
            }
        }
    }
    

    相关文章

      网友评论

        本文标题:[蓝桥杯]FJ的字符串

        本文链接:https://www.haomeiwen.com/subject/htcwthtx.html