Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6 R 1 P 2 G 3 r 1 p 2 g 3
Sample Output
19 18 10 -17 -14 -4
JAVA CODE
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
int n = cin.nextInt();
for (int i = 0; i < n; i++) {
String string = cin.next();
int number = cin.nextInt();
int sum = 0;
if (Character.isUpperCase(string.charAt(0))) {
sum = string.charAt(0) - 'A' + number + 1;
} else if (Character.isLowerCase(string.charAt(0))) {
sum = 'a' - string.charAt(0) + number - 1;
}
System.out.println(sum);
}
cin.close();
}
}```
网友评论