编程题0014 (from Programming Teaching Assistant (PTA))
求整数的位数及各位数字之和
对于给定的正整数N,求它的位数及其各位数字之和。
输入格式:
输入在一行中给出一个不超过109的正整数N。
输出格式:
在一行中输出N的位数及其各位数字之和,中间用一个空格隔开。
输入样例:
321
输出样例:
3 6
Answer:
#include <stdio.h>
int main(){
int n = 0, places = 0, s = 0;
scanf("%d", &n);
while(n){
places++;
s += n%10;
n = n/10;
}
printf("%d %d\n", places, s);
return 0;
}
网友评论