美文网首页
How Many Tables

How Many Tables

作者: pro_ven_ce | 来源:发表于2017-06-24 14:17 被阅读17次

    传送门

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

    input

    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

    output

    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

    sample input

    2
    5 3
    1 2
    2 3
    4 5

    5 1
    2 5

    sample output

    2
    4

    简单并查集

    #include<iostream>
    #include<vector>
    using namespace std;
    int set[100001];
    int findSet(int x)
    {
        if (set[x] != x)   //判断是否为根结点
            set[x] = findSet(set[x]);  //寻找根结点
        return set[x];
    }
    void unionSet(int a, int b)
    {
        int fa = findSet(a);
        int fb = findSet(b);
        if (fa == fb)
            return;
        set[fa] = fb;   
    }
    int main()
    {
        int t,n,m,a,b;
        cin >> t;
        while (t--)
        {
            cin >> n >> m;
            for (int i = 1; i <=n; i++) //初始化
                set[i] = i;
            for (int j = 0; j < m; j++)
            {
                cin >> a >> b;
                unionSet(a, b);
            }
            int sum = 0;
            for (int i = 1; i <= n; i++)
            {
                if (set[i] == i) 
                    sum++;   //根结点的数目即树的个数
            }
            cout << sum << endl;
        }
    }
    

    相关文章

      网友评论

          本文标题:How Many Tables

          本文链接:https://www.haomeiwen.com/subject/nvrkcxtx.html