PTA 1093 字符串A+B

作者: freesan44 | 来源:发表于2021-08-19 15:32 被阅读0次

    题目

    给定两个字符串 A 和 B,本题要求你输出 A+B,即两个字符串的并集。要求先输出 A,再输出 B,但重复的字符必须被剔除。

    输入格式:
    输入在两行中分别给出 A 和 B,均为长度不超过 10
    6
    的、由可见 ASCII 字符 (即码值为32~126)和空格组成的、由回车标识结束的非空字符串。

    输出格式:
    在一行中输出题面要求的 A 和 B 的和。

    输入样例:
    This is a sample test
    to show you_How it works
    结尾无空行
    输出样例:
    This ampletowyu_Hrk
    结尾无空行
    

    解题思路

    inputStr1 = str(input())
    # inputStr1 = "This is a sample test"
    inputStr2 = str(input())
    # inputStr2 = "to show you_How it works"
    strDic = dict()
    res = ""
    str = inputStr1 + inputStr2
    # print(str)
    for i in str:
        # print(i)
        # # 字符串不存在就写入
        if i not in strDic:
            res = res + i
            strDic[i] = 1
    print(res)
    

    相关文章

      网友评论

        本文标题:PTA 1093 字符串A+B

        本文链接:https://www.haomeiwen.com/subject/seqabltx.html