美文网首页
2020-03-27

2020-03-27

作者: joker_luo | 来源:发表于2020-03-27 21:03 被阅读0次

    1079 Total Sales of Supply Chain (25分)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki ID[1] ID[2] ... ID[Ki]

    where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    
          
        
    

    Sample Output:

    42.4
    
    #include<iostream>
    #include<cmath>
    #include<vector>
    //深度优先遍历
    //题目大意,存在某个供应链,根供应商有某种价格为p的商品,向经销商或者零售商供应该商品,每经过一个经销商或者零售商,价格
    //涨r%,只有零售商能面向消费者销售该商品。注:n为供应商和零售商的总数。根供应商标号为0. 
    // 输入 n,p,r 
    //接下来n行 表示格式为K id1,id2,id3...... 
    //K为零售商(K为0),id表示零售商商品的总数;K为供应商(K不为0),id表示向下供应的供应商或者零售商。
    // 输出,所有零售商能卖出的钱的总和。 
    using namespace std;
    typedef struct node{
        double data;
        vector<int> child;
    }node;
    int n;
    double p,r,total=0.0;
    vector<node> list;
    void dfs(int index,int depth){
        if(list[index].child.size()==0){
            total += list[index].data*pow(1+r,depth);
            return;
        }
        for(int i=0;i<list[index].child.size();++i){
            dfs(list[index].child[i],depth+1);
        }
    }
    int main(){
        scanf("%d %lf %lf",&n,&p,&r);
        list.resize(n);
        r = r/100;
        int k;
        int num;
        for(int i=0;i<n;++i){
            scanf("%d",&k);
            if(k==0){
                scanf("%lf",&list[i].data);
            }else{
                for(int j=0;j<k;++j){
                    scanf("%d",&num);
                    list[i].child.push_back(num);
                }
            }
        }
        dfs(0,0);
        printf("%.1lf",total*p);
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:2020-03-27

          本文链接:https://www.haomeiwen.com/subject/tsgruhtx.html