美文网首页
1270: 数字加密

1270: 数字加密

作者: Celia_QAQ | 来源:发表于2019-04-02 13:47 被阅读0次

Time Limit: 1 SecMemory Limit: 128 MB

Submit: 1370Solved: 1064

[Submit][Status][Web Board]

Description

输入 1 个四位数,将其加密后输出。方法是将该数每一位上的数字加9,然后除以10 取余,

做为该位上的新数字,最后将第1 位和第3 位上的数字互换,第2 位和第4 位上的数字互

换,组成加密后的新数。

Input

输入只有一个正整数

Output

输出加密后的新数

Sample Input

1257

Sample Output

The encrypted number is 4601


水题,我刷不出来其实真的只是因为看漏了输出,眼睛真的差!!!

AC代码:

#include<stdio.h>

#include<iostream>

#include<string.h>

using namespace std;

int main(){

int i,z,x,c,v,n;

int repeat;

scanf("%d",&n);

z=n%10;

x=n/100%10;

c=n/10%10;

v=n/1000;

z=(z+9)%10;

x=(x+9)%10;

c=(c+9)%10;

v=(v+9)%10;

printf("The encrypted number is %d%d%d%d\n",c,z,v,x);

return 0;

}

相关文章

网友评论

      本文标题:1270: 数字加密

      本文链接:https://www.haomeiwen.com/subject/zjxgbqtx.html