D - Maximum Product
UVA - 11059
Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.
解法:对于序列S,找到相邻的子序列,使子序列的乘积最大。范围很小,用枚举法,枚举起点 i,终点 j,对之间的数求积。
忘记在每次循环前初始化ans,所以 WA 很多次
代码:
#include<iostream>
using namespace std;
int main()
{
long long a[25];
int n,num=0;
while(scanf("%d",&n)!=EOF){
long long ans=0,mul;
num++;
for(int i=0;i<n;i++)
cin>>a[i];
for(int i=0;i<n;i++){
for(int j=i;j<n;j++){
mul=1;
for(int k=i;k<=j;k++){
mul*=a[k];
}
if(mul>ans)
ans=mul;
}
}
cout<<"Case #"<<num<<": The maximum product is "<<ans<<"."<<endl<<endl;
}
return 0;
}
网友评论