美文网首页
CUC-SUMMER-3-B

CUC-SUMMER-3-B

作者: Nioge | 来源:发表于2017-08-03 00:42 被阅读0次
B - Least Common Multiple
HDU - 1019

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296


解法:求最小公倍数,注意第一个数先除以最大公约数再乘第二个数,防止内存爆掉

代码:

#include<iostream>
using namespace std;
int gcd(int a,int b){
    return b?gcd(b,a%b):a;
}
int lcm(int a,int b){
    return a/gcd(a,b)*b;
}
int main()
{
    int num;
    cin>>num;
    for(int one=0;one<num;one++){
        int s;
        int a[100000];
        cin>>s;
        for(int i=0;i<s;i++)
            cin>>a[i];
        int x=a[0];
        for(int i=1;i<s;i++)
            x= lcm(x,a[i]);
        cout<<x<<endl;
    }
    return 0;
}

相关文章

  • CUC-SUMMER-3-B

    B - Least Common Multiple HDU - 1019 The least common mul...

网友评论

      本文标题:CUC-SUMMER-3-B

      本文链接:https://www.haomeiwen.com/subject/cpdulxtx.html