Hangover

作者: SmYing | 来源:发表于2018-03-07 20:54 被阅读0次

Time Limit:1000MSMemory Limit:10000K

Total Submissions:132355Accepted:64399

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2+1/3=5/6 card lengths. In general you can makencards overhang by 1/2+1/3+1/4+...+1/(n+1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n+1). This is illustrated in the figure below.

image

Input

The input consists of one or more test cases, followed by a line containing

the number 0.00 that signals the end of the input. Each test case is a

single line containing a positive floating-point number c whose value is

at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve

an overhang of at least c card lengths. Use the exact output format

shown in the examples.

Sample Input

1.00

3.71

0.04

5.19

0.00

Sample Output

3 card(s)

61 card(s)

1 card(s)

273 card(s)

Source

Mid-Central USA 2001

地址

http://poj.org/problem?id=1003


我的代码

#include <stdio.h>
int main(){
    double c;
    while(scanf("%lf",&c) != EOF)
    {
        if(c!=0.00 && c>=0.01 && c<=5.20)
        {
            int card=0,n=2;
            double sum=0;
            while(sum<c)
            {
                sum += 1.00/n;
                n++;
                card++;
            }
            printf("%d card(s)\n", card);
            
        }
        
    }
    
    return 0;
}

while(scanf("%lf",&c) != EOF)
{
if(c!=0.00 && c>=0.01 && c<=5.20)
改为
while(scanf("%lf",&c) != 0.00)
{
if(c>=0.01 && c<=5.20)
时会出现 Time Limit Exceeded 错误

相关文章

网友评论

      本文标题:Hangover

      本文链接:https://www.haomeiwen.com/subject/cvpsfftx.html