For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767, we'll get:
7766 - 6677 = 1089\ 9810 - 0189 = 9621\ 9621 - 1269 = 8352\ 8532 - 2358 = 6174\ 7641 - 1467 = 6174\ ... ...
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0, 10000).
Output Specification:
If all the 4 digits of N are the same, print in one line the equation "N
N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.
Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
分析:
简单题
主要考的是阅读理解(笑),输入一个四位数字,让它的数字从大到小排列-从小到大排,知道得到一个神奇的数6174为止
主要是两个函数to_array和to_num,排序用sort就行了。
code:
#include<cstdio>
#include<algorithm>
using namespace std;
void to_array(int n,int a[]){
for(int i=0;i<4;i++){
a[i]=n%10;
n=n/10;
}
}
int to_number(int a[]){
int sum=0;
for(int i=0;i<4;i++){
sum=sum*10+a[i];
}
return sum;
}
bool cmp(int a,int b){
return a>b;
}
int main(){
int n=0;
int max,min=0;
int a[10];
scanf("%d",&n);
while(1){
to_array(n,a);
sort(a,a+4);
min=to_number(a);
sort(a,a+4,cmp);
max=to_number(a);
n=max-min;
printf("%04d - %04d = %04d\n",max,min,n);
if(n==6174||n==0)
break;
}
system("pause");
return 0;
}
网友评论