编写一个函数,输入一行字符,将此字符串中最长的单词输出。
输入格式:
输入仅一行,多个单词,每个单词间用一个空格隔开。单词仅由小写字母组成。所有单词的长度和不超过100000。
输出格式:
如有多个最长单词,输出最先出现的。
输入样例:
I am a student
输出样例:
student
这道题 不要用set装string set会默认排序好 题目要求输入最先出现的最长单词
#include <stdio.h>
#include <set>
#include <iostream>
#include <string>
#include <sstream>
using namespace std;
string srr[100001];
int main() {
string s;
getline(cin, s);
stringstream stream(s);
string w;
int maxlen = 0;
while (stream >> w) {
int s = w.size();
if (srr[s].size() == 0) {
srr[s] = w;
maxlen = max(maxlen, s);
}
}
cout << srr[maxlen] << endl;
return 0;
}
网友评论