美文网首页
1005 Spell It Right (20)

1005 Spell It Right (20)

作者: 沙_狸 | 来源:发表于2018-08-05 09:38 被阅读0次

题目信息

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five

代码

#include<iostream>
using namespace std;
int main(){
    string word[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
    string n;cin>>n;
    int sum;
    for(int i=0;i<n.length();i++) sum+=n[i]-'0';
    string s=to_string(sum);
    for(int i=0;i<s.length();i++){
      if(i==0) cout<<word[s[i]-'0'];
      else cout<<" "<<word[s[i]-'0']; 
    }
    return 0;
}

测试结果

image.png

相关文章

网友评论

      本文标题:1005 Spell It Right (20)

      本文链接:https://www.haomeiwen.com/subject/ddgzpftx.html