美文网首页
CUC-SUMMER-4-H

CUC-SUMMER-4-H

作者: Nioge | 来源:发表于2017-08-04 09:53 被阅读0次
    H - ID Codes
    UVA - 146

    It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure — all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people’s movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)
    An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.
    For example, suppose it is decided that a code will contain exactly 3 occurrences of ‘a’, 2 of ‘b’ and 1 of ‘c’, then three of the allowable 60 codes under these conditions are:
    abaabc
    abaacb
    ababac
    These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.
    Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message ‘No Successor’ if the given code is the last in the sequence for that set of characters.

    Input
    Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single ‘#’.

    Output
    Output will consist of one line for each code read containing the successor code or the words ‘No Successor’.

    Sample Input
    abaacb
    cbbaa

    Sample Output
    ababac
    No Successor


    题意:求一个字符串有没有下一个字典排序,如果有则输出下一个字典排序

    解法:找到最后一对正序字符,即 a[i] < a[i+1] ,证明需要从a[i]往后重新排列,从a[i+1]向后找到大于a[i]的最小值与a[i]交换位置,再将a[i+1]之后的序列重新排列

    代码:

    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int main()
    {
        char a[50];
        while(cin>>a&&a[0]!='#'){
            int n=strlen(a);
            int flag=0,i;
            for(i=n-1;i>0;i--){
                if(a[i]>a[i-1]){
                    flag=-1;
                    break;
                }
            }
            if(flag==0){
                cout<<"No Successor"<<endl;
                continue;
            }
            else{
                int sub=99999;
                for(int j=i;j<n;j++)
                    if(a[j]>a[i-1])
                        if(a[j]-a[i-1]<sub){
                            sub=a[j]-a[i-1];
                            flag=j;
                        }
                int temp=a[i-1];
                a[i-1]=a[flag];
                a[flag]=temp;
                sort(a+i,a+n);
            }
            cout<<a<<endl;
        }
    }
    

    相关文章

      网友评论

          本文标题:CUC-SUMMER-4-H

          本文链接:https://www.haomeiwen.com/subject/dqcvlxtx.html