美文网首页
关于加法A + B Problem II 大整数相加

关于加法A + B Problem II 大整数相加

作者: 碧影江白 | 来源:发表于2016-08-06 10:38 被阅读80次

    A + B Problem II
    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 72497 Accepted Submission(s): 13352

    Problem Description

    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

    Sample Input

    2

    1 2

    112233445566778899 998877665544332211

    Sample Output

    Case 1:

    1 + 2 = 3

    Case 2:

    112233445566778899 + 998877665544332211 = 1111111111111111110

    巧妙的解题方法,将字符型数据转换为一位的整型数据加进位。

    #include<stdio.h>
    #include <stdlib.h>
    #include <string.h>
    void main()
    {
        int i, j, k, l, n, m;
        char a[1010],b[1010];
        int h[1100] ;
        scanf("%d", &n);
        for (i = 0;i < n;i++)
        {
            for (j=0;j<1010;j++)
                h[j]=0;
            j=0;
            printf("Case %d:\n",i+1);
            scanf("%s%s", a, b);
            printf("%s+%s=",a,b);
            k = strlen(a) - 1;
            l = strlen(b) - 1;
            while (k >= 0 && l >= 0)
            {
                if (h[j] + (a[k] - '0') + (b[l] - '0') >= 10)
                {
                    h[j] = (h[j] + (a[k] - '0') + (b[l] - '0')) % 10;
                    h[j + 1]++;
                    
                }
                else
                    h[j] = h[j] + (a[k] - '0') + (b[l] - '0');
                j++;
                k--;
                l--;
            }
                while(k >= 0)
            {
                if (h[j] + (a[k] - '0') >= 10)
                {
                    h[j] = (h[j] + a[k] - '0') % 10;
                    h[j + 1]++;
                }
                else
                    h[j] = h[j] + a[k] - '0';
                j++;
                k--;
            }
            while(l >= 0)
            {
                if (h[j] + (b[l] - '0') >= 10)
                {
                    h[j] = (h[j] + b[l] - '0') % 10;
                    h[j + 1]++;
                }
                else
                    h[j] = h[j] + b[l] - '0';
                j++;
                l--;
            }
            for (;h[j] == 0;j--);
            for (k = j;k >= 0;k--)
                printf("%d", h[k]);
            printf("\n");
            if(i!=n-1)
                printf("\n");
        }
    }
    

    相关文章

      网友评论

          本文标题: 关于加法A + B Problem II 大整数相加

          本文链接:https://www.haomeiwen.com/subject/dweksttx.html