数据结构实验之排序一:一趟快排
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
给定N个长整型范围内的整数,要求输出以给定数据中第一个数为枢轴进行一趟快速排序之后的结果。
Input
连续输入多组数据,每组输入数据第一行给出正整数N(N < = 10^5),随后给出N个长整型范围内的整数,数字间以空格分隔。
Output
输出一趟快速排序后的结果,数字间以一个空格间隔,行末不得有多余空格。
Example Input
8
49 38 65 97 76 13 27 49
Example Output
27 38 13 49 76 97 65 49
/*--------------------------------------
Name:QuickSort
Author:Mr.z
Time:2016.11.09
----------------------------------------*/
#include <iostream>
using namespace std;
void swap(int arr[],int low,int high){//-------------------------------交换函数。
int temp=arr[low];
arr[low]=arr[high];
arr[high]=temp;
}
int Partition(int arr[],int low,int high){//------------------------------寻找基准点函数。
int point_value;
point_value=arr[low];
while(low < high){
while (low < high && arr[high] >= point_value)
high--;
swap(arr,low,high);
while (low < high && arr[low] <= point_value)
low++;
swap(arr,low,high);
}
return low;
}
void QuickSort(int arr[],int low,int high){
int point;
if(low < high){
point = Partition(arr,low,high);//--------------快速排序核心,寻找基准点。
//QuickSort(arr,low,point-1);//---------------左半边区间递归。
//QuickSort(arr,point+1,high);//---------------右半边区间递归。
}
}
int main(){
int n,i=0,arr[100001];
while(cin >> n){
for(i=0;i<n;i++)
cin >> arr[i];//--------------------------------读入数据
QuickSort(arr,0,n-1);//-----------------------------快速排序
for(i=0;i<n-1;i++)
cout << arr[i] << " ";
cout << arr[i] << endl;//------------------------输出数据
}
return 0;
}
/***************************************************
User name: zhxw150244李政
Result: Accepted
Take time: 0ms
Take Memory: 168KB
Submit time: 2016-12-15 20:42:53
****************************************************/
网友评论