美文网首页
HDU 2039 三角形

HDU 2039 三角形

作者: itbird01 | 来源:发表于2022-04-20 07:08 被阅读0次

    Problem Description
    给定三条边,请你判断一下能不能组成一个三角形。

    Input
    输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;

    Output
    对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。

    Sample Input

    2 1 2 3 2 2 2

    Sample Output

    NO YES

    java code

    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner scanner = new Scanner(System.in);
            int n = scanner.nextInt();
            while (n != 0) {
                int a = scanner.nextInt();
                int b = scanner.nextInt();
                int c = scanner.nextInt();
                boolean isSan = false;
                if (a + b > c && a + c > b && b + c > a) {
                    isSan = true;
                }
                if (isSan) {
                    System.out.println("YES");
                } else {
                    System.out.println("NO");
                }
                n--;
            }
            scanner.close();
        }
    }```

    相关文章

      网友评论

          本文标题:HDU 2039 三角形

          本文链接:https://www.haomeiwen.com/subject/ehbtsrtx.html