美文网首页
1057 数零壹 (20 分)

1057 数零壹 (20 分)

作者: 蜜糖_7474 | 来源:发表于2018-12-18 18:21 被阅读0次

给定一串长度不超过 105 的字符串,本题要求你将其中所有英文字母的序号(字母 a-z 对应序号 1-26,不分大小写)相加,得到整数 N,然后再分析一下 N 的二进制表示中有多少 0、多少 1。例如给定字符串 PAT (Basic),其字母序号之和为:16+1+20+2+1+19+9+3=71,而 71 的二进制是 1000111,即有 3 个 0、4 个 1。

输入格式:

输入在一行中给出长度不超过 105 、以回车结束的字符串。

输出格式:

在一行中先后输出 0 的个数和 1 的个数,其间以空格分隔。

输入样例:

PAT (Basic)

输出样例:

3 4

AC代码:

#include <cstdio>
#include <iostream>
#include <string>

using namespace std;

int getNum(string& s) {
    int ans = 0;
    for (auto it = s.begin(); it != s.end(); it++) {
        if (*it >= 'A' && *it <= 'Z')
            ans += *it - 'A' + 1;
        else if (*it >= 'a' && *it <= 'z')
            ans += *it - 'a' + 1;
        else continue;
    }
    return ans;
}

int main() {
    string s;
    getline(cin, s);
    int n = getNum(s);
    int n0 = 0, n1 = 0;
    while (n) {
        if (n % 2) n1++;
        else n0++;
        n /= 2;
    }
    printf("%d %d", n0, n1);
    return 0;
}

总结:

简单题

相关文章

网友评论

      本文标题:1057 数零壹 (20 分)

      本文链接:https://www.haomeiwen.com/subject/geglkqtx.html