美文网首页
2020-03-07

2020-03-07

作者: joker_luo | 来源:发表于2020-03-07 21:09 被阅读0次

1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

      
    

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

      
    

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题意大概是输入两个数N,M(<=2000),接下来N行数据,每行第一列为学生ID,第二行为C成绩,第三行为M成绩,第四行为E成绩,(都为int),接下来输入M行学生ID,输出这些学生A(平均排名成绩,需自己算)>C>M>E(同排名重要性排行)中排名最高的排名以及科目,如果不存在这个学生ID则输出N/A。

#include<iostream>
using namespace std;
typedef struct student{
    string str;
    int c;
    int m;
    int e;
    int a;
}student;
int main(){
    void bestRank(string str,student arr[],int length);
    int m,n;
    student arr[2001];
    string str[2001];
    cin>>m>>n;
    int i=0,j=0;
    for(i;i<m;++i){
        cin>>arr[i].str>>arr[i].c>>arr[i].m>>arr[i].e;
        arr[i].a = (arr[i].c+arr[i].m+arr[i].e)/3;
    }
    for(j;j<n;j++){
        cin>>str[j];
    }
    for(int k=0;k<j;++k){
        bestRank(str[k],arr,i);
    }
    return 0;
}
//bestRank()查询输入学生id为str的在arr数组中rank最高的某项成绩。
void bestRank(string str,student arr[],int length){
    int index=-1;
    //找到当前字符在结构体中的位置 
    for(int i=0;i<length;++i){
        if(str==arr[i].str){
            index = i;
            break;
        }
    }
    if(index!=-1){
        int rank[4]={1,1,1,1};//默认排名为1 
        for(int i=0;i<length;++i){
            //存在比当前字符串平均成绩高的,排名下降一位 
            if(arr[i].a>arr[index].a&&i!=index){
                rank[0]++;
            }
            if(arr[i].c>arr[index].c&&i!=index){
                rank[1]++;
            }
            if(arr[i].m>arr[index].m&&i!=index){
                rank[2]++;
            }
            if(arr[i].e>arr[index].e&&i!=index){
                rank[3]++;
            }           
        } 
        //rank[0]代表A, rank[1]代表C,rank[2]代表M,rank[3]代表E
        int index=999999;
        int sign=-1;
        for(int i=0;i<4;i++){
            if(rank[i]<index){
                index = rank[i];
                sign = i;
            }
        }
        if(sign==0){
            printf("%d A\n",rank[0]);
        }   
        if(sign==1){
            printf("%d C\n",rank[1]);
        }
        if(sign==2){
            printf("%d M\n",rank[2]);
        }
        if(sign==3){
            printf("%d E\n",rank[3]);
        }
    }
    else{
        printf("N/A\n");
    }
} 

相关文章

  • git notes

    title: git notesdate: 2020-03-07 01:13:12tags: 工具 hexocat...

  • 【漫画优选】斗破苍穹

    简介 状态[连载中] 作者[天蚕土豆 任翔] 更新[2020-03-07] 最新[第834话 海角天涯,两鬓生华(...

  • 观察视角

    中原焦点团队 高艳峰 信阳 网络中级九期 坚持分享第703天 2020-03-07 错过了周四刘友龙老师...

  • 淘书小助手隐私协议

    **生效日期:2020-03-07 ** 淘书(以及以下提到的“我們”,“我們的”或“此應用程序”。)由主體公司提...

  • 每天日常隐私协议

    **生效日期:2020-03-07 ** 每天日常(以及以下提到的“我們”,“我們的”或“此應用程序”。)由主體公...

  • 你喜欢谁就去追,因为——

    2020-03-07 回来了? 我还没来得及给你做饭呢! 女:那我点外卖吧,你吃什么? 我看看哈 女:等我回个信息...

  • 产品创新地图:4个问题逼出成果--1

    编号:研习社2020-03-07 并不是每一篇混沌大学的课程,吴叔都会推荐。但能学习和借鉴,帮助落地的课程...

  • 2020-03-07

    2020-03-07 星期六 一、亿万富翁制造机分享 早上起床照镜子,看着自己的眼睛:美女,早上好!我爱你。吻! ...

  • 看书/《被讨厌的勇气》

    2020-03-07/03-08 昨日由于写推文已经没有多余的精力日更日记了。 忙着写女神节的广告推文。 对了,昨...

  • 读完这本书,让我想去伊朗转转

    2020-03-07 星期六 晴第184段文字 1 之前读过一本书《追风筝的人》。 看后觉得难以抑制内心的波澜,...

网友评论

      本文标题:2020-03-07

      本文链接:https://www.haomeiwen.com/subject/ggfkdhtx.html