美文网首页
1024寻找子串位置

1024寻找子串位置

作者: star_night | 来源:发表于2017-04-17 20:32 被阅读0次

    题目描述 Description

    给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置。

    输入描述 Input Description

    仅一行包含两个字符串a和b

    输出描述 Output Description

    仅一行一个整数

    样例输入 Sample Input

    abcd bc

    样例输出 Sample Output

    2

    代码

    #include<stdio.h>
    #include<string.h>
    int main()
    {
      char a[100],b[100];
      scanf("%s%s",a,b);
      int len1,len2;
      len1=strlen(a);
      len2=strlen(b);
      int i,j,t;
      for(i=0;i<len1-len2+1;i++){
        t=1;
        for(j=0;j<len2;j++){
          if(a[i+j]!=b[j]){
            t=0;
            break;
          }
        }
        if(t){
          printf("%d",i+1 );
        }
      }
      return 0;
    }
    
    

    相关文章

      网友评论

          本文标题:1024寻找子串位置

          本文链接:https://www.haomeiwen.com/subject/hphxzttx.html