美文网首页
12:最长平台

12:最长平台

作者: 恰我年少时 | 来源:发表于2022-05-06 13:51 被阅读0次

    http://noi.openjudge.cn/ch0109/12/
    描述
    已知一个已经从小到大排序的数组,这个数组的一个平台(Plateau)就是连续的一串值相同的元素,并且这一串元素不能再延伸。例如,在 1,2,2,3,3,3,4,5,5,6中1,2-2,3-3-3,4,5-5,6都是平台。试编写一个程序,接收一个数组,把这个数组最长的平台找出 来。在上面的例子中3-3-3就是最长的平台。
    输入
    第一行有一个整数n(n <= 1000),为数组元素的个数。第二行有n个整数,整数之间以一个空格分开。
    输出
    输出最长平台的长度。
    样例输入

    10
    1 2 2 3 3 3 4 5 5 6
    

    样例输出

    3
    
    #include <iostream>
    using namespace std;
    int main() {
        int n;
        cin>>n;
        int search[1000];
        for(int i=0;i<n;i++){
            scanf("%d",&search[i]);
        }
        int maxlength = 1;
        int nowlength;
        for(int i = 0;i<n-1;i++){
            nowlength = 1;
            while(search[i+1]==search[i]){
                nowlength++;
                i++;
                maxlength = maxlength>nowlength?maxlength:nowlength;
            }
        }
        cout<<maxlength;
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:12:最长平台

          本文链接:https://www.haomeiwen.com/subject/ihtzyrtx.html