美文网首页
1001. A+B Format (20)

1001. A+B Format (20)

作者: EvilPomelo | 来源:发表于2017-08-17 10:29 被阅读21次

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

题目大意:
输入:两个数字中间一个空格,求和
输出:将和以标准格式化输出(每三位数一个,)

#include <iostream>
#include <string>
using namespace std;
int main() {
  int a, b;
  cin >> a >> b;
  string s = to_string(a + b);
  int len = s.length();
  for (int i = 0; i < len; i++) {
    cout << s[i];
    if (s[i] == '-') continue;
    if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";
  }
  return 0;
}

相关文章

网友评论

      本文标题:1001. A+B Format (20)

      本文链接:https://www.haomeiwen.com/subject/insgrxtx.html