美文网首页
PAT A1042 Shuffling Machine (20)

PAT A1042 Shuffling Machine (20)

作者: ranerr_ | 来源:发表于2019-07-19 18:56 被阅读0次

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, 
    H1, H2, ..., H13, 
    C1, C2, ..., C13, 
    D1, D2, ..., D13, 
    J1, J2
    

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
    Input Specification:
    Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.
    Output Specification:
    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
    

    一次代码:
    思路:

    1. 按题意模拟

    分析:

    1. 其实这里用cout输出也可以,这样能够省去c_str()的转换,只是coutprintf不能混用
    #include <iostream>
    #include <string>
    #include <vector>
    using namespace std;
    int main() {
      vector<string> deck = {
        "0",
        "S1", "S2", "S3", "S4", "S5", "S6", "S7", "S8", "S9", "S10", "S11", "S12", "S13",
        "H1", "H2", "H3", "H4", "H5", "H6", "H7", "H8", "H9", "H10", "H11", "H12", "H13",
        "C1", "C2", "C3", "C4", "C5", "C6", "C7", "C8", "C9", "C10", "C11", "C12", "C13",
        "D1", "D2", "D3", "D4", "D5", "D6", "D7", "D8", "D9", "D10", "D11", "D12", "D13",
        "J1", "J2"
      }, deck1 = deck;
      int repeat_time, shuffle[55] = {};
      scanf("%d", &repeat_time);
      if (repeat_time)
        for (int i = 1; i <= 54; i++) {
          scanf("%d", &shuffle[i]);
        }
      while (repeat_time--) {
        for (int i = 1; i <= 54; i++) {
          deck1[shuffle[i]] = deck[i];
        }
        deck = deck1;
      }
      printf("%s", deck[1].c_str());
      for (auto it = deck.begin() + 2; it != deck.end(); it++) {
        printf(" %s", (*it).c_str());
      }
      return 0;
    }
    

    其他形式代码:
    思路:还是模拟
    分析:

    1. 建立了从0到53的数值ID,从而不用存字符串而是可以存数值
    2. 注意:char数组的容量在使用字符串初始化时要比字符数量大1,但是如果以数组元素的形式初始化则不用
    #include <cstdio>
    using namespace std;
    int main() {
        int cnt;
        scanf("%d", &cnt);
        int start[55], end[55], scan[55];
        for(int i = 1; i < 55; i++) {
            scanf("%d", &scan[i]);
            end[i] = i;
        }
        for(int i = 0; i < cnt; i++) {
            for(int j = 1; j < 55; j++)
                start[j] = end[j];
            for(int k = 1; k < 55; k++)
                end[scan[k]] = start[k];
        }
        char c[6] = {"SHCDJ"};
        for(int i = 1; i < 55; i++) {
            end[i] = end[i] - 1;
            printf("%c%d", c[end[i]/13], end[i]%13+1);
            if(i != 54) printf(" ");
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:PAT A1042 Shuffling Machine (20)

          本文链接:https://www.haomeiwen.com/subject/iqbslctx.html