美文网首页
【MAC 上学习 C++】Day 51-4. 实验9-4 计算两

【MAC 上学习 C++】Day 51-4. 实验9-4 计算两

作者: RaRasa | 来源:发表于2019-10-14 19:41 被阅读0次

实验9-4 计算两个复数之积 (15 分)

1. 题目摘自

https://pintia.cn/problem-sets/13/problems/568

2. 题目内容

本题要求实现一个计算复数之积的简单函数。

函数接口定义:

struct complex multiply(struct complex x, struct complex y);
其中struct complex是复数结构体,其定义如下:

struct complex{
int real;
int imag;
};

输入样例:

3 4 5 6

输出样例:

(3+4i) * (5+6i) = -9 + 38i

3. 源码参考
#include <iostream>

using namespace std;

struct complex{
    int real;
    int imag;
};

struct complex multiply(struct complex x, struct complex y);

int main()
{
    struct complex product, x, y;

    cin >> x.real >> x.imag >> y.real >> y.imag;
    product = multiply(x, y);
    cout << "(" << x.real << " + " << x.imag << "i) * (" << y.real << " + " << y.imag << "i) = " << product.real << " + " << product.imag << "i" << endl;

    return 0;
}

struct complex multiply(struct complex x, struct complex y)
{
  struct complex s;

  s.real = x.real * y.real - x.imag * y.imag;
  s.imag = x.real * y.imag + x.imag * y.real;

  return s;
}

相关文章

网友评论

      本文标题:【MAC 上学习 C++】Day 51-4. 实验9-4 计算两

      本文链接:https://www.haomeiwen.com/subject/iqwxmctx.html