美文网首页
2020-03-23

2020-03-23

作者: joker_luo | 来源:发表于2020-03-23 21:22 被阅读0次

    1025 PAT Ranking (25分)

    Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

    registration_number final_rank location_number local_rank
    
          
        
    

    The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

    Sample Input:

    2
    5
    1234567890001 95
    1234567890005 100
    1234567890003 95
    1234567890002 77
    1234567890004 85
    4
    1234567890013 65
    1234567890011 25
    1234567890014 100
    1234567890012 85
    
          
        
    

    Sample Output:

    9
    1234567890005 1 1 1
    1234567890014 1 2 1
    1234567890001 3 1 2
    1234567890003 3 1 2
    1234567890004 5 1 4
    1234567890012 5 2 2
    1234567890002 7 1 5
    1234567890013 8 2 3
    1234567890011 9 2 4
    
    #include<iostream>
    #include<vector>
    #include<algorithm> 
    using namespace std;
    typedef struct Rank{
        long long int number;
        int score;
        int final_rank;
        int local_no;
        int local_rank;
    }RankList;
    int cmp(RankList p1,RankList p2){
        if(p1.score==p2.score){
            return p1.number<p2.number;
        }else{
            return p1.score>p2.score;
        }
        return 0;
    }
    int main(){
        vector<RankList> list;
        int n,k;
        cin>>n;
        for(int i=0;i<n;++i){
            cin>>k;
            vector<RankList> tem(k);
            for(int j=0;j<k;++j){
                scanf("%lld %d",&tem[j].number,&tem[j].score);
                tem[j].local_no = i+1;
            }
            sort(tem.begin(),tem.end(),cmp);
            tem[0].local_rank = 1;
            list.push_back(tem[0]);
            for(int q=1;q<k;++q){
                if(tem[q].score==tem[q-1].score){
                    tem[q].local_rank = tem[q-1].local_rank;
                    list.push_back(tem[q]);
                }
                else{
                    tem[q].local_rank = q+1;
                    list.push_back(tem[q]);
                }
            }
        }
        sort(list.begin(),list.end(),cmp);
        list[0].final_rank = 1;
        for(int q=1;q<list.size();++q){
            if(list[q].score==list[q-1].score){
                list[q].final_rank = list[q-1].final_rank;
            }
            else{
                list[q].final_rank = q+1;
            }
        }
        printf("%d\n",list.size());
        for(int i=0;i<list.size();++i){
            printf("%013lld %d %d %d\n",list[i].number,list[i].final_rank,list[i].local_no,list[i].local_rank);
            //学号不足13位要用0补齐
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:2020-03-23

          本文链接:https://www.haomeiwen.com/subject/jxpgyhtx.html