美文网首页
1142 Maximal Clique(25 分)

1142 Maximal Clique(25 分)

作者: _YuFan | 来源:发表于2018-08-19 00:19 被阅读0次
1142 Maximal Clique(25 分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory)

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

题意:
clique是一个无向图的点的子集,clique里每两个不同的点都是相连的。最大clique是不能扩展更多相连点的clique。
判断给定的点的子集是否为一个最大的clique。

思路:
将输入存在一个二维数组(矩阵)内,对于每一个查询,先判断是否为clique(每两个点对应的二维数组为1),再判断是否为max clique(遍历给定点之外的点是否和给定的点都有连线)。

题解:

#include<cstdlib>
#include<cstdio>
#include<vector>
using namespace std;
int vertex[210][210];

int main() {
    int nv, ne, m;
    scanf("%d %d", &nv, &ne);
    for (int i = 0; i < ne; i++) {
        int a, b;
        scanf("%d %d", &a, &b);
        vertex[a][b] = vertex[b][a] = 1;
    }
    scanf("%d", &m);
    for (int i = 0; i < m; i++) {
        int k;
        scanf("%d", &k);
        vector<bool> v(nv+1);
        vector<int> verts;
        for (int j = 0; j < k; j++) {
            int t;
            scanf("%d", &t);
            verts.push_back(t);
            v[t] = true;
        }
        //判断是否为clique
        //只要给定查询中的每两个点对应矩阵上的值为0,说明它不是clique
        bool isClique = true;
        for (int j = 0; j < verts.size(); j++) {
            for (int r = j + 1; r < verts.size(); r++) {
                if (vertex[verts[j]][verts[r]] == 0) {
                    printf("Not a Clique\n");
                    isClique = false;
                    break;
                }
            }
            if (!isClique) break;
        }

        if (!isClique) continue;
        
        //如果是clique,
        //并且还存在给定之外的点与给定的所有点对应矩阵的值为1
        //说明其不是max clique
        bool notMaximal = false;
        for (int j = 1; j <= nv; j++) {
            if (v[j] == true) continue;
            bool isMaxClique = false;
            for (int r = 0; r < verts.size(); r++) {
                if (vertex[j][verts[r]] == 0) {
                    isMaxClique = true;
                    break;
                }
            }
            if (!isMaxClique) {
                printf("Not Maximal\n");
                notMaximal = true;
                break;
            }
        }
        if (!notMaximal) printf("Yes\n");
    }
    return 0;
}

相关文章

网友评论

      本文标题:1142 Maximal Clique(25 分)

      本文链接:https://www.haomeiwen.com/subject/kruqiftx.html