美文网首页
hdoj1754 I Hate It

hdoj1754 I Hate It

作者: 科学旅行者 | 来源:发表于2016-07-31 20:28 被阅读10次

题目:

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。这让很多学生很反感。不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
Input
本题目包含多组测试,请处理到文件结束。在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。学生ID编号分别从1编到N。第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
Output
对于每一次询问操作,在一行里面输出最高成绩。
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
Sample Output
5
6
5
9
Hint
Huge input,the C function scanf() will work better than cin

此题是中文题目,就是基本的线段树操作。

参考代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define N 200000+20
using namespace std;
struct node { //建立节点;
    int left,right;
    int max;
} e[4 * N];
int a[N];
void init() {
    memset(a,0,sizeof(a));
    memset(e,0,sizeof(e));
}
void input(int n) {
    for (int i = 1;i <= n;++i) {
        scanf("%d", &a[i]);
    }
}
void build(int p,int l,int r) { //创建线段树;
    e[p].left = l;
    e[p].right = r;
    e[p].max = a[l];
    if (l != r) {
        int mid = (l + r) / 2;
        build(2*p,l,mid);
        build(2*p+1,mid+1,r);
        e[p].max = max(e[p*2].max,e[p*2+1].max);
    }
}
void update(int p,int pos,int val) { //更新线段树的某个节点的值;
    if (e[p].left == e[p].right) {
        e[p].max = val;
    }
    else {
        int mid = (e[p].left+e[p].right) / 2;
        if (pos <= mid) update(2*p,pos,val);
        else update(2*p+1,pos,val);
        e[p].max = max(e[2*p].max,e[2*p+1].max);
    }
}
int query(int p,int l,int r) { //查找某个区间的最大值;
    if (l <= e[p].left && e[p].right <= r) {
        return e[p].max;
    }
    int ans = 0;
    int mid = (e[p].left+e[p].right) / 2;
    if (l <= mid) ans = max(ans,query(p*2,l,r));
    if (r > mid) ans = max(ans,query(p*2+1,l,r));
    return ans;
}
int main() {
    int n,m;
    while (scanf("%d%d", &n, &m) != EOF) {
        init();
        input(n);
        build(1,1,n);
        char c;
        for (int i = 1;i <= m;++i) {
            scanf(" %c", &c);
            int x,y;
            if (c == 'Q') {
                scanf("%d%d", &x, &y);
                int ans = query(1,x,y);
                printf("%d\n", ans);        
            }
            else {
                int std,val;
                scanf("%d%d", &std, &val);
                update(1,std,val);
            }
        }   
    }
    return 0;
}

相关文章

  • hdoj1754 I Hate It

    题目: Problem Description很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数...

  • LABEL

    I hate labels as much as I hate being labeled. I hate bei...

  • I HATE HIM

    I hate him I hate him I feel I never could be happy again...

  • 囚徒

    分享歌词: I hate you I love you, I hate that I love you, Don'...

  • I hate

    I hate we are alone in the universe I hate everthing is g...

  • complicated human beings

    I hate snobbery & gossip. That is not to say, I hate snob...

  • 【日记】Religion

    I hate being the crowd I hate human I wanna cry, yawn, sc...

  • 翻译 恨无时 艾米莉.狄金森

    I had no time to hate, because恨无时 I had no time to hate, ...

  • I had no time to hate, because

    I had no time to hate, because I had no time to hate, bec...

  • 蚊子

    我恨 I hate 我好恨 I hate it 恨我太过弱小 Hate me for being too weak...

网友评论

      本文标题:hdoj1754 I Hate It

      本文链接:https://www.haomeiwen.com/subject/lrcxsttx.html