美文网首页
1097 Deduplication on a Linked L

1097 Deduplication on a Linked L

作者: W杂货铺W | 来源:发表于2018-11-25 23:58 被阅读0次

    Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​ ) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
    Then N lines follow, each describes a node in the format:

    Address Key Next

    where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4
    ​​ , and Next is the position of the next node.

    Output Specification:

    For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

    Sample Input:

    00100 5
    99999 -7 87654
    23854 -15 00000
    87654 15 -1
    00000 -15 99999
    00100 21 23854

    Sample Output:

    00100 21 23854
    23854 -15 99999
    99999 -7 -1
    00000 -15 87654
    87654 15 -1

    分析

    • 结构体数组存储第一遍读的链表,下标即地址
    • 根据起始地址遍历一遍链表,01数组p标志key值的绝对值是否出现过,两种情况分别push到vk和vr向量中
    • 遍历一遍vk,vr输出两个链表

    code

    #include <iostream>
    #include <vector>
    #include <cmath>
    using namespace std;
    
    struct node{
        int ad,key,next;
    }Node[100000];
    
    int p[10001];
    vector<node> vk,vr;
    
    int main()
    {
        int start,n;
        scanf("%d %d",&start,&n);
        int a,b,c;
        for(int i=0;i<n;i++){
            scanf("%d%d%d",&a,&b,&c);
            Node[a] = {a,b,c};
        }
        for(int i=start;i!=-1;i=Node[i].next){
            if(p[abs(Node[i].key)]==1){
                vr.push_back(Node[i]);
            }else{
                p[abs(Node[i].key)]=1;
                vk.push_back(Node[i]);
            }
        }
        for(int i=0;i<vk.size();i++){
            if(i==0){
                printf("%05d %d",vk[i].ad,vk[i].key);
            } else {
                printf(" %05d\n%05d %d",vk[i].ad,vk[i].ad,vk[i].key);
            }
            if(i==vk.size()-1){
                printf(" -1\n");
            }
        }
    
         for(int i=0;i<vr.size();i++){
            if(i==0){
                printf("%05d %d",vr[i].ad,vr[i].key);
            } else {
                printf(" %05d\n%05d %d",vr[i].ad,vr[i].ad,vr[i].key);
            }
            if(i==vr.size()-1){
                printf(" -1\n");
            }
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:1097 Deduplication on a Linked L

          本文链接:https://www.haomeiwen.com/subject/lwxvqqtx.html