美文网首页
C语言实现 PTA 1042 字符统计

C语言实现 PTA 1042 字符统计

作者: Thorrrrc | 来源:发表于2019-12-01 18:36 被阅读0次

    请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

    输入格式:

    输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

    输出格式:

    在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

    输入样例:
    This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........
    
    输出样例:
    e 7
    
    #include <stdio.h>
    #include <string.h>
    #include <ctype.h> 
    int main(int argc, char *argv[])
    {
        int a[127] = {0},i,max = 0,imax = 0;
        char b[1001];
        gets(b);
        for(i = 0;i < strlen(b);i++){
            if(islower(b[i])){
                a[b[i]]++; 
            }else if(isupper(b[i])){
                a[b[i]+32]++;
            }
        }
        max = a[97];
        imax = 97;
        for(i = 97;i <= 122;i++){
            if(max < a[i]){
                max = a[i];
                imax = i;
            }else if(max == a[i]){
                if(i-imax<0){
                    max = a[i];
                    imax = i;
                }
            }
        }
        printf("%c %d",imax,max);
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:C语言实现 PTA 1042 字符统计

          本文链接:https://www.haomeiwen.com/subject/nbftgctx.html