美文网首页
1025单词翻转

1025单词翻转

作者: star_night | 来源:发表于2017-04-17 22:00 被阅读0次

    题目描述 Description

    给出一个英语句子,希望你把句子里的单词顺序都翻转过来

    输入描述 Input Description

    输入包括一个英语句子。

    输出描述 Output Description

    按单词的顺序把单词倒序输出

    样例输入 Sample Input

    I love you

    样例输出 Sample Output

    you love I

    代码

    #include<stdio.h>
    #include<string.h>
    int main()
    {
      char a[100];
      char b[100][20];
      fgets(a,100,stdin);
      int i,j,t=0,len1;
      len1=strlen(a);
      for(i=0,j=0;i<len1;i++){//将每个单词存入数组b
        if(a[i]=='\n')
          continue;
        if(a[i]==' '){
          j++;
          t=0;
          continue;
        }
        b[j][t++]=a[i];
      }
      for(i=j;i>=0;i--){//数组b逆序输出
        printf("%s",b[i]);
        if(i!=0)
          printf(" ");
      }
      return 0;
    }
    

    相关文章

      网友评论

          本文标题:1025单词翻转

          本文链接:https://www.haomeiwen.com/subject/nnjxzttx.html