美文网首页
[HDU] 1253 胜利大逃亡 解题报告

[HDU] 1253 胜利大逃亡 解题报告

作者: vouv | 来源:发表于2017-03-26 12:02 被阅读0次

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

13 3 4 200 1 1 10 0 1 10 1 1 11 1 1 11 0 0 10 1 1 10 0 0 00 1 1 00 1 1 0

Sample Output

11

PS

典型的bfs题目,需要注意的是主角在城堡中有6个方向可以走。

AcCode

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<cmath>
using namespace std;
int dx[7] = {0,1,0,-1,0,0 };//6个方向可移动
int dy[7] = {0,0,1,0,-1,0};
int dz[7] = {1,0,0,0,0,-1};
int q[52][52][52];
int vis[52][52][52];//1代表已经走过
int A, B, C,time;
typedef struct node {
    int x;
    int y;
    int z;
    int time;
};

//判断函数,保证该位置在城堡内且可以去
int pd(int x, int y, int z) {
    if (x >= 0 && x < A&&y >= 0 && y < B&&z >= 0 && z < C&&q[x][y][z] == 0)return 1;
    else return 0;
}

int bfs(int t) {
    queue<node>p;
    node start, end;
    start.x = 0; 
    start.y = 0;
    start.z = 0; 
    start.time = 0;
    p.push(start);
    memset(vis, 0, sizeof(vis));
    vis[0][0][0] = 1;
    while (!p.empty()) {
        start = p.front();
        p.pop();
        if (start.time > t) {
            printf("%d\n", start.time);
            return -1;
        }
        if (start.x == A - 1 && start.y == B - 1 && start.z == C - 1 && start.time <= t)return start.time;
        for (int i = 0; i < 6; i++) {
            end.x = start.x + dz[i];
            end.y = start.y + dx[i];
            end.z = start.z + dy[i];
            if (pd(end.x, end.y, end.z) && !vis[end.x][end.y][end.z]) {
                vis[end.x][end.y][end.z] = 1;
                end.time = start.time + 1;
                if (abs(end.x - A + 1) + abs(end.y - B + 1) + abs(end.z - C + 1)+end.time < t)p.push(end);
            }
        }
}
    return -1;
}
int main() {
    int k;
    scanf("%d", &k);
    for (int b = 0; b < k; b++) {
        scanf("%d%d%d%d", &A, &B, &C, &time);
        for (int i = 0; i < A; i++) {
            for (int j = 0; j < B; j++) {
                for (int p = 0; p < C; p++) {
                    scanf("%d", &q[i][j][p]);
                }
            }
        }        
            printf("%d\n",bfs(time));
            continue;

    }
    return 0;
}

相关文章

  • [HDU] 1253 胜利大逃亡 解题报告

    Problem Description Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃...

  • HDOJ 1002 A + B Problem II

    [TOC] 解题报告 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid...

  • 无标题文章

    I - A Simple Math Problem(解题报告) HDU - 5974 第一次写,一道比较简单...

  • HDU2312 Cliff Climbing

    首先附上通道:hdu2312 HDU2312,这题是我去年寒假做的题,前不久又看到了去年写的解题报告,感觉还是很有...

  • 胜利大逃亡

    在讲述胜利大逃亡的故事前,先好好说一下丛林战斗鸡 说起鸡来,那故事可多啦! 大公鸡,象征吉利,喜庆,总和过年过节,...

  • 胜利大逃亡

    3 初稿日期 2018 12 19 修改日期 2019 8 2 胜利大逃亡 ...

  • 胜利大逃亡

    时间过得飞快,转眼间十多天已过,终于熬到了考试的时候! 不管十多天的过程如何、复习得怎么费劲,丑媳妇早晚得见公婆,...

  • 胜利大逃亡

    老船长和鼻涕虫被抓进了海底世界动物园,被一群老虎、狼和野猪紧紧地包围着。看着他们狼狈的神情,鱼儿们一个个笑得趴在了...

  • 胜利大逃亡

    傍晚六点多我们在落日余晖中排队做HS,夕阳西下将天空映得一片橘红,彩云飘飞。突然接到物业管家的电话,可以开证明离开...

  • [HDU] 2602 Bone Collector 解题报告

    Problem Description Input The first line contain a intege...

网友评论

      本文标题:[HDU] 1253 胜利大逃亡 解题报告

      本文链接:https://www.haomeiwen.com/subject/notkottx.html