美文网首页
digit Generator

digit Generator

作者: 净土_0342 | 来源:发表于2018-05-06 12:52 被阅读0次

1583 Digit Generator
For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N, we call N a generator of M. For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256. Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207. You are to write a program to find the smallest generator of the given integer.
Input .Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N,
1 ≤ N ≤ 100, 000.
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print ‘0’.

Sample Input
3
216
121
2005
Sample Output
198
0
1979

code

#include <iostream>
#include<cstring>
#define maxn 100005
int main() {
    int ans[maxn];
    int T,n;
    memset(ans,0,sizeof(ans));
    for(int m=0;m<maxn;m++){
        int x = m, y = m; // 遍历,由生成元求数
        while(x>0){y += x%10;x/=10;} // 
        if(ans[y] == 0) ans[y] = m; // 直接求最小的.当没有赋值时才能赋值,意味着这里的赋值量是最小值,因为m是递增的.
    }
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        printf("%d\n",ans[n]);
    }
    return 0;
}

一次遍历最后查表的方法,很强.

相关文章

  • digit Generator

    1583 Digit GeneratorFor a positive integer N, the digit-s...

  • 1583 - Digit Generator

    输入一个数,找出这个数的最小生成元。生成元的意思是:一个整数,比如245,它本身加上它各位数之和等于256 (= ...

  • UVa1583 Digit Generator -- Java

    我在 github 上建立了一个 repo,专门记录自己对刘汝佳的《算法竞赛入门经典(第二版)》中每个 UVa 例...

  • grep ip

    egrep '[[:digit:]]{1,3}.[[:digit:]]{1,3}.[[:digit:]]{1,3}...

  • 3-3 数数字(Digit Counting , ACM/ICP

    1225 - Digit Counting 习题3-3 数数字(Digit Counting , ACM/ICPC...

  • one plus

    Easy, Math Question 一个数以digit序列的形式给出,加一返回对应digit序列 Notes ...

  • Digit Counts

    Count the number of k's between 0 and n. k can be 0 - 9. ...

  • Digit Recognizer

    手写数字识别是非常经典的入门级实践项目了,MNIST则是用来初步检验一个图像分类方法好坏的不二之选数据集。之前练习...

  • SQL练习-用SQL处理数列

    ​生成连续编号 生成0~99的数。 select d1.digit+(d2.digit *10) as seq f...

  • Variable Digit Count Sort.

    Θ(n) where n is the total digit count

网友评论

      本文标题:digit Generator

      本文链接:https://www.haomeiwen.com/subject/ojfurftx.html