美文网首页
PAT-A-1033 To Fill or Not to Fil

PAT-A-1033 To Fill or Not to Fil

作者: 黑夜里不灭的路灯 | 来源:发表于2019-02-21 11:42 被阅读0次

    1033 To Fill or Not to Fill(25 分)

    With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

    Input Specification:
    Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

    Output Specification:
    For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = Xwhere X is the maximum possible distance the car can run, accurate up to 2 decimal places.

    Sample Input 1:
    50 1300 12 8
    6.00 1250
    7.00 600
    7.00 150
    7.10 0
    7.20 200
    7.50 400
    7.30 1000
    6.85 300
    Sample Output 1:
    749.17

    Sample Input 2:
    50 1300 12 2
    7.10 0
    7.00 600
    Sample Output 2:
    The maximum travel distance = 1200.00

    加油站的贪心问题
    贪心:
    按照距离从小到大排序
    如果现在加油站(a)的价格在最大可达范围内有比现在低的价格(b)加油站,则将油正好加到到b.
    如果现在加油站(a)的价格在最大可达范围内没有比现在低的价格,找比a站高的最低的(b)加油站,则将油加满,到b在做下一次抉择.
    寻找最低价格的方式是一样的,都是第一段的那个代码

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn = 510;
    const int INF = 100000000;
    struct station
    {
        double price,dis;
    } st[maxn];
    bool cmp(station a,station b)
    {
        return a.dis<b.dis;
    }
    int main()
    {
        int n;
        double Cmax,D,Davg;
        cin>>Cmax>>D>>Davg>>n;
        for(int i=0; i<n; i++)
        {
            cin>>st[i].price>>st[i].dis;
        }
        st[n].price = 0;
        st[n].dis= D;
        sort(st,st+n,cmp);
        if(st[0].dis!=0)
        {
            printf("The maximum travel distance = 0.00\n");
        }
        else
        {
            int now = 0;
            double ans = 0,nowTank = 0,Max=Cmax*Davg;
            while(now < n)
            {
                int k =-1;
                double priceMin = INF;
                for(int i=now+1; i<=n&&st[i].dis-st[now].dis<=Max; i++)
                {
                    if(st[i].price<priceMin)
                    {
                        priceMin = st[i].price;
                        k=i;
                        if(priceMin < st[now].price)
                        {
                            break;
                        }
                    }
                }
                if(k==-1) break;
                double need=(st[k].dis-st[now].dis)/Davg;
                if(priceMin < st[now].price)
                {
                    if(nowTank < need)
                    {
                        ans+=(need - nowTank)*st[now].price;
                        nowTank = 0;
                    }
                    else
                    {
                        nowTank-=need;
                    }
    
                }
                else
                {
                    ans += (Cmax-nowTank)*st[now].price;
                    nowTank = Cmax-need;
                }
                now = k;
            }
            if(now == n)
            {
                printf("%.2f\n",ans);
            }
            else
            {
                printf("The maximum travel distance = %.2f\n",st[now].dis+Max);
            }
        }
    }
    

    相关文章

      网友评论

          本文标题:PAT-A-1033 To Fill or Not to Fil

          本文链接:https://www.haomeiwen.com/subject/orkryqtx.html