美文网首页
HDU 2105 The Center of Gravity

HDU 2105 The Center of Gravity

作者: itbird01 | 来源:发表于2022-04-03 22:14 被阅读0次

Problem Description

Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked

leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then

on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also

have known every object has its Center of Gravity.

Now,you have been given the coordinates of three points of a triangle. Can you calculate the center

of gravity of the triangle?

Input

The first line is an integer n,which is the number of test cases.

Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.

The input is terminated by n = 0.

Output

For each case, print the coordinate, accurate up to 1 decimal places.

Sample Input

2 1.0 2.0 3.0 4.0 5.0 2.0 1.0 1.0 4.0 1.0 1.0 5.0 0

Sample Output

3.0 2.7 2.0 2.3

Source

HDU 2007-6 Programming Contest

设在三角形ABC中,A(x1,y1)B(x2,y2)C(x3,y3),则重心坐标为(x1+x2+x3/3,y1+y2+y3/3)

JAVA CODE


import java.text.DecimalFormat;

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {

        Scanner cin = new Scanner(System.in);

        DecimalFormat format = new DecimalFormat("0.0");

        while (cin.hasNextInt()) {

            int n = cin.nextInt();

            if (n == 0) {

                break;

            }

            for (int i = 0; i < n; i++) {

                double x1 = cin.nextDouble();

                double y1 = cin.nextDouble();

                double x2 = cin.nextDouble();

                double y2 = cin.nextDouble();

                double x3 = cin.nextDouble();

                double y3 = cin.nextDouble();

                System.out.println(format.format((x1 + x2 + x3) / 3) + " " + format.format((y1 + y2 + y3) / 3));

            }

        }

        cin.close();

    }

}```

相关文章

网友评论

      本文标题:HDU 2105 The Center of Gravity

      本文链接:https://www.haomeiwen.com/subject/ovrnjrtx.html