美文网首页
【MAC 上学习 C++】Day 54-2. 实验11-1-4

【MAC 上学习 C++】Day 54-2. 实验11-1-4

作者: RaRasa | 来源:发表于2019-10-17 20:35 被阅读0次

    实验11-1-4 计算最长的字符串长度 (15 分)

    1. 题目摘自

    https://pintia.cn/problem-sets/13/problems/591

    2. 题目内容

    本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。

    函数接口定义:

    int max_len( char *s[], int n );
    其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。

    输入样例:

    4
    blue
    yellow
    red
    green

    输出样例:

    6

    3. 源码参考
    #include <iostream>
    #include <string.h>
    #include <stdlib.h>
    
    using namespace std;
    
    #define MAXN 10
    #define MAXS 20
    
    int max_len( char *s[], int n );
    
    int main()
    {
        int i, n;
        char *string[MAXN] = {NULL};
    
        cin >> n;
        for(i = 0; i < n; i++) 
        {
            string[i] = (char *)malloc(sizeof(char)*MAXS);
            cin >> string[i];
        }
    
        cout << max_len(string, n) << endl;
    
        return 0;
    }
    
    int max_len( char *s[], int n )
    {
      int i, k, m;
    
      m = 0;
      for(i = 0; i < n; i++)
      {
        k = strlen(s[i]);
        if(m < k)
        {
          m = k;
        }
      }
        
      return m;
    }
    

    相关文章

      网友评论

          本文标题:【MAC 上学习 C++】Day 54-2. 实验11-1-4

          本文链接:https://www.haomeiwen.com/subject/pcbhmctx.html