美文网首页
PAT 甲级 刷题日记|A 1099 Build A Bina

PAT 甲级 刷题日记|A 1099 Build A Bina

作者: 九除以三还是三哦 | 来源:发表于2021-08-10 17:15 被阅读0次

    题目

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.

    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

    • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:

    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    结尾无空行
    

    Sample Output:

    58 25 82 11 38 67 45 73 42
    结尾无空行
    

    思路

    二叉排序树,给定结构建树,利用性质(二叉树的中序遍历结果就是升序序列)填充树,然后进行层次遍历即可。

    根据题目输入形式,给定下标编号,静态方式实现树比较简单。

    代码

    #include <bits/stdc++.h>
    using namespace std;
    
    const int maxn = 103;
    int len;
    int indexs = 0;
    int num[maxn];
    vector<int> res;
    
    struct node{
        int data;
        int leftchild;
        int rightchild;
    }Node[maxn];
    
    void Inorder(int root) {
        if (root == -1) return;
        Inorder(Node[root].leftchild);
        Node[root].data = num[indexs++];
        Inorder(Node[root].rightchild);
    }
    
    void level(int root) {
        queue<int> myqueue;
        myqueue.push(root);
        while (!myqueue.empty()) {
            int now = myqueue.front();
            res.push_back(Node[now].data);
            myqueue.pop();
            if (Node[now].leftchild != -1) myqueue.push(Node[now].leftchild);
            if (Node[now].rightchild != -1) myqueue.push(Node[now].rightchild);
        }
    }
    
    int main(){
        cin>>len;
        for (int i = 0; i < len; i++) {
            cin>>Node[i].leftchild>>Node[i].rightchild;
        }
        for (int i = 0; i < len; i++) {
            cin>>num[i];
        }
        sort(num, num+len);
        Inorder(0);
        level(0);
        for (int i = 0; i < len; i++) {
            cout<<res[i];
            if(i != len - 1) cout<<" ";
        }
    }
    

    相关文章

      网友评论

          本文标题:PAT 甲级 刷题日记|A 1099 Build A Bina

          本文链接:https://www.haomeiwen.com/subject/pogzvltx.html