美文网首页
Bone Collector

Bone Collector

作者: DongBold | 来源:发表于2017-03-26 19:51 被阅读14次

    Bone Collector

    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

    Input

    The first line contain a integer T , the number of cases.

    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

    Output

    One integer per line representing the maximum of the total value (this number will be less than 2 31).

    Sample Input

    1

    5 10

    1 2 3 4 5

    5 4 3 2 1

    Sample Output

    14

    一个简单背包, 根据状态转移方程就能做了:

    dp[j] = max(dp[j], dp[j-w[i]] + v[i]);
    
    #include <bits/stdc++.h>
    using namespace std;
    
    int main() {
        int T;
        int n, v;
        int value[10005];
        int weight[10005];
        scanf("%d", &T);
        while(T--) {
            int dp[10005];
            memset(dp, 0, sizeof dp);
            scanf("%d%d", &n, &v);
            for(int i = 0; i < n; i++) {
                scanf("%d", &value[i]);
            }
            for(int j = 0; j < n; j++) {
                scanf("%d", &weight[j]);
            }
            for(int i = 0; i < n; i++) {
                for (int j = v; j >= weight[i]; j--) {
                    dp[j] = max(dp[j], dp[j - weight[i]] + value[i]);
                }
            }
            printf("%d\n", dp[v]);
        }
    
        return 0;
    }
    
    

    相关文章

      网友评论

          本文标题:Bone Collector

          本文链接:https://www.haomeiwen.com/subject/poikottx.html