1054 The Dominant Color (20 分)
Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224 ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
分析:
本题要求在给定的序列中找出超过半数并且占比最大的元素,考查map的用法。因为digital color最大值超过long long范围(9.22337e+018),因此定义成string类型较为合适。
#include<iostream>
#include <map>
using namespace std;
map<string,int> mp;
int main(){
int m,n;
cin>>m>>n;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
string a;
cin>>a;
mp[a]++;
}
}
string pixel;
int maxcnt=0;
for(auto it : mp){
if(maxcnt<it.second){
maxcnt=it.second;
pixel=it.first;
}
}
cout<<pixel;
return 0;
}
网友评论