美文网首页
1104 Sum of Number Segments(20 分

1104 Sum of Number Segments(20 分

作者: W杂货铺W | 来源:发表于2018-09-08 21:10 被阅读0次

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105​​ . The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

code

遍历

time out

// time out error
#include <iostream>

using namespace std;
int main()
{
    int n;
    float num[100000];
    int srt;
    int ed;
    float sum = 0;
    scanf("%d\n",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%f",&num[i]);
    }
    for(srt=0;srt<n;srt++)
    {
        for(ed = srt;ed<n;ed++)
        {
            for(int j=srt;j<=ed;j++)
            {
                sum = sum + num[j];
            }
        }
    }
    printf("%.2f",sum);
}

正确版

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    double num[100001];
    double sum = 0;
    for(int i=1;i<=n;i++)
    {
        cin >> num[i];
        sum = sum + num[i]*i*(n-i+1);
    }
    printf("%.2f",sum);
}

note

数学问题

相关文章

网友评论

      本文标题:1104 Sum of Number Segments(20 分

      本文链接:https://www.haomeiwen.com/subject/sevlgftx.html