美文网首页
1058 选择题 (20 分)

1058 选择题 (20 分)

作者: 蜜糖_7474 | 来源:发表于2018-12-19 20:17 被阅读0次

批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。

输入格式:

输入在第一行给出两个正整数 N(≤ 1000)和 M(≤ 100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式:

按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从 1 开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple。

输入样例:

3 4
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)

输出样例:

3
6
5
2 2 3 4

AC代码:

#include <algorithm>
#include <cstdio>
#include <iostream>
#include <set>
#include <vector>

using namespace std;

struct Problem {
    int no;
    int score;
    int all_num;
    int right_num;
    int wrong_person;
    set<char> st;
    Problem(int no, int score, int all_num, int right_num)
        : no(no),
          score(score),
          all_num(all_num),
          right_num(right_num),
          wrong_person(0) {}
};

bool setcmp(set<char> a, set<char> b) {
    if (a.size() != b.size()) return false;
    for (auto it1 = a.begin(), it2 = b.begin(); it1 != a.end(); ++it1, ++it2) {
        if (*it1 != *it2) return false;
    }
    return true;
}

bool cmp(Problem a, Problem b) { return a.wrong_person > b.wrong_person; }

int main() {
    int n, m, score, all_num, right_num;
    int max_cnt = -1, max_idx = -1;
    char c;
    vector<Problem> v;
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= m; ++i) {
        scanf("%d%d%d", &score, &all_num, &right_num);
        Problem tmp = Problem(i, score, all_num, right_num);
        for (int j = 0; j < right_num; j++) {
            cin >> c;
            tmp.st.insert(c);
        }
        v.push_back(tmp);
    }
    string line;
    getline(cin, line);  //吸收上面的一个换行符
    for (int i = 0; i < n; ++i) {
        int pos = 0, k, sum = 0;  //k为这道题选了几个选项
        getline(cin, line);
        for (int j = 0; j < m; j++, pos++) {
            set<char> st;
            pos = line.find('(', pos);
            k = line[pos + 1] - '0';
            for (int l = 0; l < k; ++l) {
                st.insert(line[pos + 3 + 2 * l]);
            }
            if (setcmp(st, v[j].st))
                sum += v[j].score;
            else
                v[j].wrong_person++;
        }
        printf("%d\n", sum);
    }
    stable_sort(v.begin(), v.end(), cmp);
    if (v[0].wrong_person == 0)
        printf("Too simple");
    else {
        printf("%d %d", v[0].wrong_person, v[0].no);
        for (int i = 1; i < v.size(); ++i) {
            if (v[i].wrong_person == v[0].wrong_person)
                printf(" %d", v[i].no);
            else break;
        }
    }
    return 0;
}

总结:

1、题目代码量有点大,有点像25分的题,为了易于理解写我了个结构体并用了sort排序,会相对耗时一些但依旧能过最后一个测试点。
2、用到了size_t string::find(char c, size_t pos=0) 这个函数
3、用到了两个set比较的方法

相关文章

网友评论

      本文标题:1058 选择题 (20 分)

      本文链接:https://www.haomeiwen.com/subject/shdskqtx.html