C - Oil Deposits
UVA - 572
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides
the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to
determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the
same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number
of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting
the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the
absence of oil, or ‘@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same
oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.
Sample Input
1 1
3 5
@@*
@
@@*
1 8
@@****@*
5 5
****@
@@@
@@
@@@@
@@**@
0 0
Sample Output
0
1
2
2
解法:宽搜典型题,题意为@和它四周相邻的@共属于一块油田,问一共有几块油田。遍历数组,如果为@,标记为,并判断其四周相邻的字符是否为@,如果是重复上面操作,直到周围都为,则找完一块油田,继续遍历寻找下一块。
代码:
#include<iostream>
using namespace std;
int m,n;
char a[102][102];
int d[8][2]={{0,-1},{0,1},{-1,0},{1,0},{-1,-1},{1,-1},{-1,1},{1,1}};
void BFS(int i,int j)
{
a[i][j]='*';
for(int x=0;x<8;x++)
if(a[i+d[x][0]][j+d[x][1]]=='@')
BFS(i+d[x][0],j+d[x][1]);
return;
}
int main()
{
while(cin>>m>>n){
int ans=0;
if(m==0&&n==0)
break;
for(int i=1;i<=m;i++)
for(int j=1;j<=n;j++)
cin>>a[i][j];
for(int i=1;i<=m;i++)
for(int j=1;j<=n;j++)
if(a[i][j]=='@'){
ans++;
BFS(i,j);
}
cout<<ans<<endl;
}
}
网友评论