美文网首页
1083 List Grades(set,运算符重载)

1083 List Grades(set,运算符重载)

作者: virgilshi | 来源:发表于2018-10-01 17:42 被阅读0次
1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:
N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
分析

本题本质上在考察结构体的排序,但是set在生成的过程是有序的,因此,我们只需重载>运算符,并且在定义set时指定是按照less排序还是按照greater排序。

#include <iostream>
#include <set>
using namespace std;
struct node {
    string name,id;
    int score;
};
bool operator>(const node &a,const node &b) {
    return a.score>b.score;
}
set<node,greater<node> >s;
int main() {
    int n,g1,g2;
    cin>>n;
    for(int i=0; i<n; i++) {
        string name,id;
        int score;
        cin>>name>>id>>score;
        s.insert(node {name,id,score});
    }
    cin>>g1>>g2;
    bool flag=false;
    for (auto t : s) {
        if(g1<=t.score && t.score<=g2) {
            cout<<t.name<<" "<<t.id<<endl;
            flag=true;
        }
    }
    if(!flag) cout<<"NONE"<<endl;
    return 0;
}

相关文章

  • 1083 List Grades(set,运算符重载)

    1083 List Grades (25 分) Given a list of N student records...

  • 1083. List Grades (25)(基础,排序)

    PAT-A1083,题目地址:https://www.patest.cn/contests/pat-a-pract...

  • 运算符重载及其他约定

    7.1 重载算术运算符 重载二元算术运算符 重载复合赋值运算符 重载一元运算符 重载比较运算符 等号运算符:‘eq...

  • C++ 部分运算符重载

    可重载的运算符 不可重载的运算符和符号 重载运算符为类的成员函数 重载运算符为友元函数 重载赋值运算符 重载流插入...

  • 2019-07-11 运算符的重载

    运算符的重载 重载运算符 (“::”,“.*”,“.”,“?:”)不能被重载。 重载运算符时,不能改变其本质,如不...

  • 运算符重载

    一.+号运算符重载 二.<<号运算符重载 三.指针运算符重载(智能指针)

  • C++运算符重载-下篇 (Boolan)

    C++运算符重载-下篇 (Boolan) 本章内容:1. 运算符重载的概述2. 重载算术运算符3. 重载按位运算符...

  • C++运算符重载-上篇 (Boolan)

    C++运算符重载-上篇 (Boolan) 本章内容:1. 运算符重载的概述2. 重载算术运算符3. 重载按位运算符...

  • C++重载

    重载 C++语言规定: 重载的运算符要保持原运算符的意义。只能对已有的运算符重载,不能增加新的运算符。重载的运算符...

  • C++运算符重载详解

    运算符重载规则 1.被重载的运算符必须是已经存在的C++运算符,不能重载自己创建的运算符; 2.运算符被重载之后,...

网友评论

      本文标题:1083 List Grades(set,运算符重载)

      本文链接:https://www.haomeiwen.com/subject/tkmnoftx.html