美文网首页
04-树5 Complete Binary Search Tre

04-树5 Complete Binary Search Tre

作者: KelvinX | 来源:发表于2017-04-24 17:09 被阅读0次

题目
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 1000≤1000). Then NN distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目大意

输入一组数据(不一定递增),让你构造一个完全二叉搜索树,且用层序输出。

做法

  1. 将输入的序列按递增排好序
  2. 排好序的序列可以通过中序构造来构造完全二叉搜索树,同时利用好左儿子是根的2倍,右儿子是根的2倍+1,这个完全二叉树的特点

代码如下

#include <stdio.h>
#include <algorithm>

using namespace std;

const int Max = 1005;
int node[Max];
int tree[Max];
int pos,n;

void build(int root){
    if(root > n)
        return;
    int left = root<<1;
    int right = (root<<1)+1;
    build(left);
    tree[root] = node[pos++];
    build(right);
}

int main(){
    int i;
    scanf("%d",&n);
    for(i=0;i<n;i++){
        scanf("%d",&(node[i]));
    }
    sort(node,node+n);
    pos = 0;
    build(1);
    printf("%d",tree[1]);
    for(i=2;i<=n;i++){
        printf(" %d",tree[i]);
    }
    return 0;
}

相关文章

网友评论

      本文标题:04-树5 Complete Binary Search Tre

      本文链接:https://www.haomeiwen.com/subject/uappzttx.html