美文网首页
大整数加法

大整数加法

作者: KN郑某某 | 来源:发表于2021-02-22 11:06 被阅读0次

时间限制:3000 ms | 内存限制:65535 KB | 难度:3

描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

输出

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.

样例输入

2
1 2zz
112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

南阳理工ACM题目-103:A+B Problem II

#include <iostream>
#include <string>
using namespace std;
    
int main()
{
    char str[1002];
    string str1,str2,ts;
    int n,a,b,k,id,m=1;
    cin >> n;
    while (n--)
    {
        cin >> str1 >> str2;
        k = id = 0;
        cout << "Case " << m ++ << ":" << endl << str1 << " + " << str2 << " = ";
        if (str1.length() < str2.length())
        {
        ts = str1;
        str1 = str2;
        str2 = ts;
        }
        a = str1.length();
        b = str2.length();
        for (int i = a-1,j=b-1; j>=0; --i,--j)
        {
        k = (str1[i] - '0') + (str2[j] - '0') + k;
        str[id++] = k % 10;
        k /= 10;
        }
        for (int i = a - b - 1; i >= 0; --i)
        {
        k = (str1[i] - '0') + k;
        str[id++] = k % 10;
        k /= 10;
        }
        if (k > 0)cout << k;
        for (int i = id - 1; i >= 0; --i)
        {
        cout << char(str[i] + '0');
        }
        cout << endl;
    }
    //system("pause");
    return 0;
}

相关文章

  • 大整数加法

    题目地址:http://noi.openjudge.cn/ch0106/10/题目:总时间限制: 1000ms 内...

  • 大整数加法

  • 大整数加法

    时间限制:3000 ms | 内存限制:65535 KB | 难度:3 描述 I have a very si...

  • 2981大整数加法

    最后得考虑都为0的情况。

  • 655. 大整数加法

    以字符串的形式给出两个非负整数 num1 和 num2,返回 num1 和 num2 的和。注意事项:num1 和...

  • 0023-大整数加法

    问题描述 求两个不超过 200 位的非负整数的和。 输入 有两行,每行是一个不超过 200 位的非负整数,没有多余...

  • js 实现大整数加法

    问题描述实现‘字符串加法’,即将两个以字符串形式表示的数字相加,得到结果然后返回一个新的字符串。 例如:输入‘12...

  • 整数加法

    题目描述:请设计一个算法能够完成两个用字符串存储的整数进行相加操作,对非法的输入则返回error输入描述:输入为一...

  • c/c++大整数加法

    刚入门编程语言的同学可能对大整数加法合乘法有点小头疼。在这里就给大家分享下。希望对大家有所帮助。下面进入正题 De...

  • 高精度数(大整数)加法

    高精度数的加法 什么是高精度数? 高精度数是指一种数据范围超过long long 的数。 题目描述 求两个不超过2...

网友评论

      本文标题:大整数加法

      本文链接:https://www.haomeiwen.com/subject/uwwhxltx.html