美文网首页
1107. Social Clusters (30)

1107. Social Clusters (30)

作者: 陈洲 | 来源:发表于2017-02-26 23:19 被阅读0次

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki
: hi
[1] hi
[2] ... hi
[Ki
]
where Ki
(>0) is the number of hobbies, and hi
[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
3:2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

#include <iostream>
#include <vector>
#include <algorithm>
#define MAX 1001
using namespace std;

vector<int> M(MAX,0);


int root(int a)
{
    while(M[a]>0) a = M[a];
    return a;
}

int Union(int a, int b)
{
    int ra = root(a);
    int rb = root(b);
    if(ra!=rb)
    {
        M[ra]+=M[rb];
        M[rb] = ra;
    }
    return ra;
}
bool compare(int a, int b){ return a>b?true:false; }
int main()
{
    int N;
    int k;
    int r;
    int temp;
    vector<int> result;
    cin >> N;
    for(int i=0; i<N; i++)
    {
        scanf("%d: ", &k);
        cin >> temp;
        r = root(temp);
        for(int j=1; j<k; j++)
        {
            cin >> temp;
            r = Union(temp,r);
        }
        M[r]--;
    }
    for(int i=0; i<1001; i++)
    {
        if(M[i]<0)
            result.push_back(-M[i]);
    }

    sort(result.begin(),result.end(),compare);
    cout << result.size() << endl;
    for(int i=0; i<result.size(); i++)
    {
        if(i!=0)
            cout << " ";
        cout << result[i];
    }
    return 0;

}

相关文章

网友评论

      本文标题:1107. Social Clusters (30)

      本文链接:https://www.haomeiwen.com/subject/whvawttx.html