美文网首页
算法训练 删除数组零元素

算法训练 删除数组零元素

作者: 就这样吧嘞 | 来源:发表于2019-03-19 19:50 被阅读0次

    从键盘读入n个整数放入数组中,编写函数CompactIntegers,删除数组中所有值为0的元素,其后元素向数组首端移动。注意,CompactIntegers函数需要接受数组及其元素个数作为参数,函数返回值应为删除操作执行后数组的新元素个数。输出删除后数组中元素的个数并依次输出数组元素。
    样例输入: (输入格式说明:5为输入数据的个数,3 4 0 0 2 是以空格隔开的5个整数)
    5
    3 4 0 0 2
    样例输出:(输出格式说明:3为非零数据的个数,3 4 2 是以空格隔开的3个非零整数)
    3
    3 4 2
    样例输入:
    7
    0 0 7 0 0 9 0
    样例输出:
    2
    7 9
    样例输入:
    3
    0 0 0
    样例输出:
    0

    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int a = sc.nextInt();
        int sum =0;
        int cunchu[]=new int [a];
        for(int i=0;i<a;i++) {
            cunchu[i]=sc.nextInt();
            if(cunchu[i]!=0) {
                sum++;
            }
        }
        System.out .println(sum);
        for(int i=0;i<a;i++) {
            if(cunchu[i]!=0) {
                System.out .print(cunchu[i]+" ");
            }
            
        }
        
        }   
    }
    

    相关文章

      网友评论

          本文标题:算法训练 删除数组零元素

          本文链接:https://www.haomeiwen.com/subject/wwanmqtx.html