美文网首页
1077 Kuchiguse(字符串处理)

1077 Kuchiguse(字符串处理)

作者: virgilshi | 来源:发表于2018-10-02 20:06 被阅读0次

1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

分析

本题本质是求给定的多个字符串的共同后缀。

#include <iostream>
#include <algorithm>
using namespace std;
int main(){
    int n;
    string s1;
    cin>>n;
    getchar();
    getline(cin,s1);
    for(int k=1;k<n;k++){
        string s2;
        getline(cin,s2);
        int i=s1.length()-1,j=s2.length()-1;
        string tmp;
        while(i>=0 && j>=0){
            if(s1[i]==s2[j]) tmp.push_back(s1[i]);
            else break;
            i--,j--;
        }
        s1=tmp;
        reverse(s1.begin(), s1.end());
    }
    if(s1.length()!=0) cout<<s1<<endl;
    else cout<<"nai"<<endl;
    return 0;
}

相关文章

网友评论

      本文标题:1077 Kuchiguse(字符串处理)

      本文链接:https://www.haomeiwen.com/subject/xgyaoftx.html