1009 Product of Polynomials (25)(25 分)
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
这个问题有一个小坑,小数部分0.45的时候浮点表示为0.4499999999
牛客网会约成0.4
#include <iostream>
#include <cstdio>
using namespace std;
int main(){
int a,b;
double x[2][110]={},y[2][110]={},z[3001]={};
cin>>a;
for (int i=0;i<a;i++){
cin>>x[0][i]>>x[1][i];
}
cin>>b;
for (int i=0;i<b;i++){
cin>>y[0][i]>>y[1][i];
}
int c,n=0;
double d;
for (int i=0;i<a;i++){
for (int j=0;j<b;j++){
c=x[0][i]+y[0][j];
d=x[1][i]*y[1][j];
if (z[c]!=0)n--;
z[c]+=d;
if (z[c]!=0)n++;
}
}
cout<<n;
for (int i=3000;i>=0;i--){
if (z[i]!=0){
printf(" %d %0.1f",i,z[i]);
}
}
}
网友评论