美文网首页
1094 The Largest Generation (25

1094 The Largest Generation (25

作者: W杂货铺W | 来源:发表于2018-11-25 23:13 被阅读0次

    A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

    Input Specification:

    Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

    ID K ID[1] ID[2] ... ID[K]

    where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

    Sample Input:

    23 13
    21 1 23
    01 4 03 02 04 05
    03 3 06 07 08
    06 2 12 13
    13 1 21
    08 2 15 16
    02 2 09 10
    11 2 19 20
    17 1 22
    05 1 11
    07 1 14
    09 1 17
    10 1 18

    Sample Output:

    9 4

    分析

    设置数组dep存储每个depth下节点个数,dfs遍历一遍树,再在dep中找到最大值和所在位置即可

    code

    #include <iostream>
    #include <vector>
    
    using namespace std;
    
    struct node{
        vector<int> child;
        int depth;
    };
    
    vector<node> v;
    vector<int> dep;
    void dfs(int root,int depth){
        v[root].depth = depth;
        dep[depth]+=1;
        if(v[root].child.size()==0){
            return ;
        }
        for(int i=0;i<v[root].child.size();i++){
            dfs(v[root].child[i],depth+1);
        }
    }
    
    
    
    int main()
    {
        int n,m;
        scanf("%d%d",&n,&m);
        v.resize(n+1);
        dep.resize(n+1);
        int a,b,c;
        for(int i=0;i<m;i++){
            scanf("%d %d",&a,&b);
            for(int j=0;j<b;j++){
                scanf("%d",&c);
                v[a].child.push_back(c);
            }
        }
        dfs(1,1);
        int maxd=1,maxg=1;
        for(int i=1;i<n;i++){
            if(dep[i]>maxd){
                maxd = dep[i];
                maxg = i;
            }
        }
        printf("%d %d",maxd,maxg);
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:1094 The Largest Generation (25

          本文链接:https://www.haomeiwen.com/subject/yyomqqtx.html