美文网首页
Uva11572 Unique Snowflakes

Uva11572 Unique Snowflakes

作者: 科学旅行者 | 来源:发表于2016-12-15 16:21 被阅读63次

    题目:

    Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow, one by one, into a package. Once the package is full, it is closed and shipped to be sold.
    The marketing motto for the company is “bags of uniqueness.” To live up to the motto, every snowflake in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the snowflakes flowing through the machine are identical. Emily would like to know the size of the largest possible package of unique snowflakes that can be created. The machine can start filling the package at any time, but once it starts, all snowflakes flowing from the machine must go into the package until the package is completed and sealed. The package can be completed and sealed before all of the snowflakes have flowed out of the machine.
    Input
    The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer n, the number of snowflakes processed by the machine.
    The following n lines each contain an integer (in the range 0 to 109
    , inclusive) uniquely identifying a snowflake. Two snowflakes are identified by the same integer if and only if they are identical.
    The input will contain no more than one million total snowflakes.
    Output
    For each test case output a line containing single integer, the maximum number of unique snowflakes that can be in a package.
    Sample Input
    1
    5
    1
    2
    3
    2
    1
    Sample Output
    3

    题意:输入一个长度为n的序列,找到一个尽量长的连续子序列,使得该序列中没有相同的元素。

    参考代码:

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <set>
    using namespace std;
    const int N = 1000000+10;
    
    int a[N];
    
    void init() {
        memset(a, 0, sizeof(a));
    }
    
    void input(const int n) {
        for (int i = 0;i < n;++i) {
            cin >> a[i];
        }
    }
    
    int result(const int n) {//滑动窗口;
        int l = 0, r = 0;//窗口的左端和窗口的右端;
        set<int> s;//集合, 用来保存当前出现过的数字;
        int ans = 0;
        while (r < n) {
            while (r < n && !s.count(a[r])) {//表明当前这个数字不在集合内(该数字当前还未出现过);//将这个数插入到集合中, 右窗口前移;
                s.insert(a[r]);
                ++r;
            }
            ans = max(ans, r - l);
            s.erase(a[l]);
            ++l;//删掉集合中左窗口的数并且左窗口前移, 当前窗口的最大值计算结束;
        }
        return ans;
    }
    
    int main() {
        ios::sync_with_stdio(false);
        cin.tie(NULL);
        int t;
        cin >> t;
        while (t--) {
            int n;
            cin >> n;
            init();
            input(n);
            int ans = result(n);
            cout << ans << endl;    
        }
        return 0;
    }
    

    相关文章

      网友评论

          本文标题:Uva11572 Unique Snowflakes

          本文链接:https://www.haomeiwen.com/subject/zrrgmttx.html